Arbeitszeitberechnung inkl. Pause in Excel

Ich stand vor der Herausforderung aus zwei Werten (Arbeitsbeginn und Arbeitsende) die Arbeitszeit inkl. Pause zu berechnen. d.h. es sollte die gesetzlichen Pausenzeiten abgezogen werden. Dies alles sollte in einer Formel untergebracht werden und sowohl für Tagdienst als auch Nachtdienst funktionieren.

time time management stopwatch 3933688
Image by geralt from Pixabay

Zunächst einmal die Rahmenbedingungen: Unter 6 Stunden gibt es keine Pause, zwischen 6 und 9 Stunden sind es 30 Minuten und über 9 Stunden 45 Minuten. Die berechnete Arbeitszeit soll in Industrieminuten ausgegeben werden.

Die Frage war aber jetzt, ob nach 6 Std. bzw. 9 Stunden Arbeit, dann noch die Pause abgezogen werden soll. Das würde bedeuten, das bei Arbeitsbeginn um 8:00 und Arbeitsende um 14:01 die Arbeitszeit bei 6:01 liegen würde, wenn jetzt 30 Minuten abgezogen würde, dann wären wir wieder bei 5:31.

Rechne ich die Pause mit ein, so müsste man erst 6:31 arbeiten um die halbe Stunde abgezogen zu bekommen. Bei 9 Stunden müsste 9:46 gearbeitet werden, damit die 45 Minuten abgezogen werden.

Ich entschied mich für den zweiten Weg und rechne die Pause erst mit ein, bevor ich sie abziehe.

Eine Formel könnte so aussehen:
=WENN(A2=””;0;WENN((B2-A2)24<0;WENN((B2-A2)24+24>9,75;(B2-A2)24+24-0,75;WENN((B2-A2)24+24>6,5;(B2-A2)24+24-0,5;(B2-A2)24+24));WENN((B2-A2)24>9,75;(B2-A2)24-0,75;WENN((B2-A2)24>6,5;(B2-A2)24-0,5;(B2-A2)*24))))

Screenshot Excel

In der Formel gibt es mehrere Wenn Funktionen, zum einen wird bei leeren A2 und B2 Feld eine 0 ausgegeben, zum anderen wird geprüft ob es Tag oder Nachdienst ist. Dies erfolgt indem B2 Minus A2 gerechnet wird. Ist es Tag so kommt eine positive Zahl heraus, ist es Nacht eine negative Zahl, die wiederum mit plus 24 wieder positiv gemacht wird. Die Felder A2 und B2 werden von Excel erstmal als Dezimalwerte berechnet, deshalb wird alles x24 gerechnet, damit wir die Stunden erhalten. Dann muss nur noch die Pause entsprechend abgezogen werden, wenn es größer 6,5 Std. bzw. 9,75 Std. ist.

Die Formatierung der Zellen A2 und B2 sollte Benutzerdefiniert und hh:mm sein. Die Arbeitszeit ist ein Zahl mit zwei Nachkommastellen.

So funktioniert es erstmal für mich, Ergänzungen oder neue Idee nehme ich aber gerne auf.

image_pdfBeitrag als PDF
Like
Like Love Haha Wow Sad Angry

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.